ブロックエディタ編集画面で区切り線が表示されない

0
いいねをした人: 居ません
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #105922
    飯田雅大
    参加者
    0

    【お使いの Snow Monkey のバージョン】
    バージョン: 17.0.4

    【お使いの Snow Monkey Blocks のバージョン】
    バージョン 16.0.1
    【お使いの Snow Monkey Editor のバージョン】
    バージョン 8.0.1
    【お使いのブラウザ】
    Chrome バージョン: 102.0.5005.61(Official Build) (arm64)
    【当該サイトのURL】

    ### 発生している問題

    ブロックエディターのブロック「区切り」が、投稿記事ページでは線が表示されるが、編集画面では表示されない。

    編集画面でも表示されるようにしたい。

    ### 試したこと

    開発者ツールでみたところ、editor.cssの以下部分がボーダーを消していることがわかった。

    html :where(.editor-styles-wrapper,.customize-control-sidebar_block_editor) .wp-block-separator {
      background-color: _var-color-light-gray();
      border: none;  ←これ
    }

    そのため、追加CSSに以下コードを追加して暫定対応

    html :where(.editor-styles-wrapper) .wp-block-separator {
      border: solid;
    }
    
    //スタイル「ドット」用
    .block-editor-block-list__block[data-type="core/separator"].wp-block-separator.is-style-dots {
      border: none;
    }

    上記対応にて、一応問題は解決しました。

    ただインストール後、特にCSSもいじっていない状態のsnow-monkeyで発生しているので、そもそもこのborder:noneが何のためにあるのかお聞きしたいです。

    何卒よろしくお願いいたします。

    0
    いいねをした人: 居ません
    #105982
    キタジマ タカシ
    参加者
    1629

    線が太くなってしまうために入れていたと思うのですが、エディター上では

    .has-text-color.has-accent-color-color.wp-block-separator
    

    なのに対し、フロントでは

    .has-text-color.has-accent-color-color.has-accent-color-background-color.has-background.wp-block-separator
    

    となっており、エディター上では背景色が抜けてしまうのでコアの不具合な気がします。とりあえず背景色ではなく border-color で対応するように変更できないか調査してみます。

    1
    いいねをした人:
    #106298
    キタジマ タカシ
    参加者
    1629

    書き込みが遅くなりました、v17.0.5 で修正しました!

    0
    いいねをした人: 居ません
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。

ドキュメント

Snow Monkey の設定方法やマニュアルを掲載しています。

ドキュメント

フォーラム

Snow Monkey の使い方やカスタマイズについてのご質問・ご要望等はサポートフォーラムで行っています。サポートフォーラムは誰でも閲覧できますが、書き込みできるのは Snow Monkey 購入者のみとなります。

サポートフォーラム

よくあるご質問

Snow Monkey のサービスについて不明な点がある場合は、まずはよくあるご質問をご確認ください。

よくあるご質問

お問い合わせ

よくあるご質問を見ても解決しなかった場合、試用版の申請については問い合わせフォームからお願いいたします。

お問い合わせ