Snow Monkey Editorの更新後エラーメッセージが表示され編集画面に入れない

0
いいねをした人: 居ません
  • このトピックには4件の返信、2人の参加者があり、最後にakosanにより1年、 1ヶ月前に更新されました。
5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #123633
    akosan
    閲覧者
    31

    【お使いの Snow Monkey のバージョン】バージョン: 20.0.2
    【お使いの Snow Monkey Blocks のバージョン】バージョン 19.2.1
    【お使いの Snow Monkey Editor のバージョン】バージョン 9.2.2
    【お使いの PHP のバージョン】PHP8.0.25
    【お使いのブラウザ】chrome
    【当該サイトのURL】https://gojiai.info/_lib/

    ### 発生している問題

    Snow Monkey BlocksとSnow Monkey Editorの更新を行ったところエラーが出て編集やカスタマイズが出来ない。

    出来ない箇所→投稿、固定ページ、カスタム投稿の各記事の編集、カスタマイザー
    画面に入る際に以下のエラーメッセージが表示される。

    (画像は管理者により削除)

    Warning: Undefined property: WP_Post_Type::$capabilities in /xxxxx/public_html/_lib/wp-includes/post.php on line 1869
    
    Fatal error: Uncaught TypeError: array_merge(): Argument #2 must be of type array, null given in /xxxxx/public_html/_lib/wp-includes/post.php:1869 Stack trace:
    #0 /xxxxx/public_html/_lib/wp-includes/post.php(1869): array_merge(Array, NULL)
    #1 /xxxxx/public_html/_lib/wp-content/plugins/snow-monkey-editor/App/Setup/CurrentUser.php(25): get_post_type_capabilities(Object(WP_Post_Type)) 
    #2 /xxxxx/public_html/_lib/wp-includes/class-wp-hook.php(308): Snow_Monkey\Plugin\Editor\App\Setup\CurrentUser->_wp_enqueue_scripts('')
    #3 /xxxxx/public_html/_lib/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #4 /xxxxx/public_html/_lib/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #5 /xxxxx/public_html/_lib/wp-admin/edit-form-blocks.php(272): do_action('enqueue_block_e...')
    #6 /xxxxx/public_html/_lib/wp-admin/post.php(187): require('/xxxxx/...')
    #7 {main} thrown in /xxxxx/public_html/_lib/wp-includes/post.php on line 1869
    

    ### 試したこと

    ・post.php on line 1869の確認

    特にカスタマイズした記憶がない

    ・My snow monkeyのプラグインを無効にしてみる

    解決せず

    ・プラグインをすべて無効にしてエラーが影響しているかを切り分け
    他プラグインではエラーメッセージが出ない

    Snow Monkey Editorを有効にした時だけエラーが起きる

    現在はSnow Monkey Editorのみ無効にして編集を行っている状態です。

     

    よろしくお願いいたします。

    0
    いいねをした人: 居ません
    #123635
    アバター画像キタジマ タカシ
    閲覧者
    2289

    ご報告ありがとうございます、確認します!

    1
    いいねをした人:
    #123636
    アバター画像キタジマ タカシ
    閲覧者
    2289

    下記ページの下部から 9.2.1 がダウンロードできるので、とりあえずダウンロード&解凍して、FTP ソフトで wp-contnet/plugins/snow-monkey-editor に上書きアップロードすれば表示されるようになるかと思います。ご迷惑おかけしてすみません。

    1
    いいねをした人:
    #123644
    アバター画像キタジマ タカシ
    閲覧者
    2289

    Snow Monkey Editor v9.2.3 で修正をいれてみました。v9.2.3 だとどうでしょうか?

    1
    いいねをした人:
    #123657
    akosan
    閲覧者
    31

    キタジマさん

    無事にエラーが出なくなり編集もできるようになりました。

    迅速なご対応ありがとうございます!

    1
    いいねをした人:
5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • トピック「Snow Monkey Editorの更新後エラーメッセージが表示され編集画面に入れない」には新しい返信をつけることはできません。

ドキュメント

Snow Monkey の設定方法やマニュアルを掲載しています。

ドキュメント

フォーラム

Snow Monkey の使い方やカスタマイズについてのご質問・ご要望等はサポートフォーラムで行っています。サポートフォーラムは誰でも閲覧できますが、書き込みできるのは Snow Monkey 購入者のみとなります。

サポートフォーラム

よくあるご質問

Snow Monkey のサービスについて不明な点がある場合は、まずはよくあるご質問をご確認ください。

よくあるご質問

お問い合わせ

よくあるご質問を見ても解決しなかった場合、試用版の申請については問い合わせフォームからお願いいたします。

お問い合わせ

Snow Monkey は Gutenberg ブロックエディターに対応した 100%GPL の WordPress テーマです。拡張性を意識した開発をおこなっており、カスタマイザーとブロックでスピーディーにサイトを立ち上げるだけでなく、CSS やフックを駆使した高度なカスタマイズにも柔軟に対応できます。