カスタマイズ結果を保存できない

14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • 投稿者
    投稿
  • #1940
    Masahiko Abe
    参加者

    #年末に色々お世話になりました。
    他テーマからSnow Monkeyに変更しよう(戻そう)としています。

    テーマの変更自体は問題無く行うことができます。
    ただ、カスタマイザーでアドセンスのコードを入れたり、SEO関連の設定を変更したりした後に「公開」ボタンを押すと、「何かうまくいかなかったようです。時間を置いてもう一度お試しください。」と表示され、カスタマイズ結果を反映することができません。

    ウィジェットについても、カスタマイザーからタイトルなどを変更すると「エラーが発生しました。リロードしてもう一度お試しください。」と表示され、保存できません。
    ただし、ダッシュボードメニューの「外観」-「ウィジェット」での設定は問題無く反映できます。

    WordPress 4.9 の構文チェック機能の影響かと、怪しそうなプラグインを外したり、子テーマを新たに作ってみたりしたのですが、状況が変わりません。

    他テーマでのカスタマイズはカスタマイザーからでも問題無く行うことができます。

    何か、他に試してみるべきことがありましたら、教えていただけると助かります。。

    0
    #1941
    キタジマ タカシ
    キーマスター

    こちらこそお世話になりました m(_ _)m

    僕もカスタマイザーの詳しい仕様はわからないのですが、経験上、「何かうまくいかなかったようです。時間を置いてもう一度お試しください。」というメッセージがでるときは JavaScript、もしくは PHP の構文エラーがでていることが原因であることが多い気がします。

    保存時にブラウザのデベロッパーツールで JavaScript のエラーがでていないか確認したり、サーバーのエラーログに PHP のエラーがでていないか確認されてみてください。

    0
    #1942
    Masahiko Abe
    参加者

    コメントありがとうございます。
    うーん、エラーは出ないですね。。
    ただ、改めて子テーマを作ってみたらうまくいったので、もういちど新たに設定し直してみます。

    0
    #1943
    Masahiko Abe
    参加者

    前言撤回で、やはり保存できないですね。。
    残りのプラグインも全て外して徹底チェックしてみます。

    0
    #1956
    キタジマ タカシ
    キーマスター

    こちら、サーバーでWAFを設定されていますでしょうか?そうの場合、オフにすると保存できると情報いただきました。

    アドセンスのscriptタグがブロックされるのかもしれません。ちょっと対策考えてみます。

    0
    #1957
    Masahiko Abe
    参加者

    お手数おかけします。プラグインを全て外してみましたが状況は変わりませんでした。

    エックスサーバーなので、WAFは対応していない認識です。XML-RPC APIとREST APIのアクセス制限はありますが、こちらとは違いますよね?
    functions.phpを空にしたり、いろいろ試しているせいかもしれませんが、エラーが出つつも設定が保存できて喜んでたら駄目になったりと、まだ試行錯誤しています。

    > アドセンスのscriptタグがブロックされるのかもしれません。ちょっと対策考えてみます。

    本件が片付いたら別途質問しようとしていましたが、関連コンテンツユニット(だと思います)が以下のエラーで表示されていません。関係ありますか?(無いかな)

    “adsbygoogle.push() error: Invalid responsive width from Matched Content slot xxxxx: 0. Please ensure to put this Matched Content slot into a non-zero width div container.”
    name
    :
    “TagError”

    0
    #1959
    キタジマ タカシ
    キーマスター

    うーん、まじですか…orz
    確かにエックスサーバーは WAF は無さそうですね。REST API はいくつかのウィジェットで使っていますが、そのせいで保存できないというのは無さそうな気もしますが…もし制限をかけられているようでしたら、解除してみて試して頂けると。
    アドセンスのエラーもカスタマイザーには関係無さそうです。

    一応確認ですが、

    – プラグインを全て無効化
    – 子テーマを使わず Snow Monkey を使用
    – アドセンス関係(カスタマイザー > 広告)については全て未入力に

    でも保存エラーになりますかね?
    あとはあるとすれば PHP のバージョンが低い、とかですが…何を使われていますでしょうか? PHP 5.6 以上であれば問題ないはずですが、5系をお使いでしたら、一度7系に上げて試してみるとどうでしょうか…?

    0
    #1960
    Masahiko Abe
    参加者

    試して駄目だったはずなのですが、今試すと子テーマを使わなければ保存エラーになりません。
    では、と最低限の記述だけ書いたstyle.cssとfunctions.phpを置いた子テーマを作ってそちらで試してみると、エラーになります。。
    広告の設定などのカスタマイズ結果が入れたばかりの子テーマでも設定済み(親テーマから引き継がれている?)のは問題ないんでしょうか。

    0
    #1961
    キタジマ タカシ
    キーマスター

    試して駄目だったはずなのですが、今試すと子テーマを使わなければ保存エラーになりません。
    では、と最低限の記述だけ書いたstyle.cssとfunctions.phpを置いた子テーマを作ってそちらで試してみると、エラーになります。。

    functions.php を空にしても NG だったと書かれていましたが、functions.php があやしいですかね…。子テーマの functions.php を消して、必須ファイルである style.cssindex.php だけの子テーマをつくって有効化し、カスタマイザーを操作してみるとどうでしょうか。

    広告の設定などのカスタマイズ結果が入れたばかりの子テーマでも設定済み(親テーマから引き継がれている?)のは問題ないんでしょうか。

    もし Snow Monkey 以外にもモンキーレンチで有料テーマをつくったときに、Snow Monkey からそのテーマに切り替えても、この設定は引き継いだほうが良いだろうな、というものは引き継ぐようにしています。子テーマもその影響で、いくつかの項目は引き継ぐようになっています。

    0
    #1973
    Masahiko Abe
    参加者

    原因分かりました。
    ご指摘の通りfunctions.phpでした。
    空にしたのですが、最後に「?>」を付けていたのが駄目でした。
    消すとエラーが出なくなりました。「?>」つけてはだめなんですね。知りませんでした。お恥ずかしい。

    functions.pspを元に戻す際にタグをタイトル横に追加するスクリプト(ユーザ用コンテンツで投稿されていたものです)をどう挿入してもエラー吐いてしまうので外しましたが、それ以外は動作するように再設定できました。

    相変わらずアドセンスの関連コンテンツユニットが表示されませんが、別事象のようなのでこちらについては確認した上で改善できないようであれば、別途ご相談します。

    お騒がせしました。

    0
    #1974
    キタジマ タカシ
    キーマスター

    消すとエラーが出なくなりました。「?>」つけてはだめなんですね。知りませんでした。お恥ずかしい。

    書くこと自体は大丈夫なのかもですが、その直後の空白文字とか改行に気をつけないとダメみたいなので、消しておくほうがベターのようです。
    参考:https://thesaibase.com/php/end-tag

    functions.pspを元に戻す際にタグをタイトル横に追加するスクリプト(ユーザ用コンテンツで投稿されていたものです)をどう挿入してもエラー吐いてしまう

    古い記事なので、現在のバージョンでは動かないということがあるのかもしれません。ちなみにどういうエラーだったか共有いただけるとうれしいです!

    相変わらずアドセンスの関連コンテンツユニットが表示されませんが、別事象のようなのでこちらについては確認した上で改善できないようであれば、別途ご相談します。

    これ、つくりはしたものの、実は僕のサイトでは PV が足りなくてテストできないんです…。もし解決策を見つけられたら、情報共有頂けるとすごく助かります。

    0
    #1975
    Masahiko Abe
    参加者

    関連コンテンツの件、別件ですが解決したのでこちらでご報告しておきます。

    widthを取得できていないようなので、以下のCSSを追加したら表示されました。

    .p-related-posts .adsbygoogle { width: 320px; margin:auto; }
    @media (min-width:500px) { .p-related-posts .adsbygoogle { width: 468px; } }
    @media (min-width:800px) { .p-related-posts .adsbygoogle{ width: 728px; } }

    サイズ等は以下のページを参考にしてそのままなので、調整の余地があると思います。
    また、位置が寄っていたのでmargin:autoを追加しています。

    タグの表示コードについては、以下のような状況です。私の挿入方法が悪いのかもしれませんが、失敗するとエラー吐いて真っ白になるので時間があるときに試してみます。

    * functions.phpの真ん中に書かれていたコードの頭に?> を追加の上で挿入
    → 動作はするが、本スレッドのエラーがカスタマイズ結果保存時に発生
    * functions.phpの最後にコード頭の<?を削除して挿入
    functions.phpのエラーで画面真っ白になります。エラー位置は?>の入っている行(だったと思います)

    0
    #1977
    キタジマ タカシ
    キーマスター

    あー!関連コンテンツ、もしかしたら、アドセンスのタグが <ul class="c-entries c-entries--rich-media"></ul> の中に入るようになっていたかもです…。ul の中だと入れ子がおかしいので、ちゃんと外に挿入されるようにすればちゃんと表示されるのかもしれません。修正してみます。

    タグの表示については、ちょっとはっきりわからないですね…。気になるので、Messanger 等で子テーマお送り頂ければ、こちらでも検証してみます。ご検討ください!

    0
    #1979
    Masahiko Abe
    参加者

    タグの表示の件、報告しようと試してみたらうまくいってしまいました。。
    動作した状態でもカスタマイズ結果の保存でのエラーも出ず。
    ひとまず問題なくなりましたので、クローズとさせていただきます。
    サポートありがとうございました。

    0
14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • トピック「カスタマイズ結果を保存できない」には新しい返信をつけることはできません。