ページを編集時にブロックのスタイルを変更すると「このブロックでエラーが発生したためプレビューできません。」と表示され、ブロックが壊れる

0
いいねをした人: 居ません
  • このトピックには8件の返信、2人の参加者があり、最後にHaseGawaにより1週、 1日前に更新されました。
9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #116720
    HaseGawa
    参加者
    16

    【お使いの Snow Monkey のバージョン 18.2.0】
    【お使いの Snow Monkey Blocks のバージョン 17.2.0】
    【お使いの Snow Monkey Editor のバージョン 9.1.0】
    【Chrome 最新版】
    【サーバー:ローカル開発環境】
    【PHPバージョン 7.4.33】
    【WordPressバージョン 6.1.1】
    【MySQLバージョン 5.7.38】

     

    ### 発生している問題

    プラグイン「User Role Editor」にて権限グループ(A)を追加し、この追加した権限グループのユーザにてページを編集時にブロックのスタイルを変更すると「このブロックでエラーが発生したためプレビューできません。」と表示され、ブロックが壊れます。
    壊れるブロックはスタイル変更可能なブロック全般です。

    管理者権限および編集者権限ユーザーにて編集時はこの現象は発生しません。
    なお、追加した権限グループの権限設定は編集者権限と全く同じ(権限グループを追加時にコピー元を編集者としています)です。

    権限グループ追加の理由は、ユーザーごとにカスタム投稿を作成しており、これの編集権限制御のためです。

    とりあえず編集者権限ををベースとして作成し後で細かく設定を行う予定でしたが、細かい設定を行う前に動作確認したら、ブロックが壊れる現象が発生となっています。
    カスタム投稿はプラグイン「Custom Post Type UI」にて作成しています。

    スタイル変更前

    スタイル変更前

    スタイル変更後スタイル変更後

    ブロックが壊れた時のデベロッパーツールのコンソールに以下が表示されました。

     

    ### 試したこと

    Snow Monkey以外のプラグインをすべて無効化。
    ブラウザのキャッシュ削除。

    以上を試しましたが変化はありませんでした。

    どなたかこの問題の解決方法や似た現象の解決に至った情報などありましたら、情報提供いただけますと大変助かります。

    0
    いいねをした人: 居ません
    #116722
    キタジマ タカシ
    参加者
    1802

    これちょっと手元で再現してみたいなと思うのですが、「権限グループ(A)」にはどれどれの権限を付与していますか?

    1
    いいねをした人:
    #116723
    キタジマ タカシ
    参加者
    1802

    あ、「編集者権限と全く同じ」でしたね、すみません!ちょっと確認してみます。

    1
    いいねをした人:
    #116741
    HaseGawa
    参加者
    16

    念の為権限設定を送ります。
    「権限グループ(A)= 札幌地区編集者 (sapporo) 」となります。

    よろしくお願いいたします。

    1
    いいねをした人:
    #116848
    キタジマ タカシ
    参加者
    1802

    ありがとうございます! 不具合箇所が特定できたので、Snow Monkey Editor の次回アップデートで修正入れてリリースします!

    0
    いいねをした人: 居ません
    #116862
    HaseGawa
    参加者
    16

    キタジマ様対応ありがとうございます。

    Snow Monkey Editor の次回アップデートで修正とのことですが、いつ頃になりますでしょうか?

    私ごとではありますが、現在作成している2月末に公開予定の顧客サイトでこの不具合に遭遇している状態です。
    早めのアップデートを行って頂けますと大変助かります。

    0
    いいねをした人: 居ません
    #116869
    キタジマ タカシ
    参加者
    1802

    ちょうど今アップデートしました(v9.1.1)! アップデートして確認してみてください!

    0
    いいねをした人: 居ません
    #116881
    HaseGawa
    参加者
    16

    キタジマ様アップデートありがとうございます。
    これから確認してみます^^

    1
    いいねをした人:
    #117014
    HaseGawa
    参加者
    16

    キタジマ様、Snow Monkey Editor を(v9.1.1)にアップデートし、正常に動作することを確認しました。

    ありがとうございました。

    1
    いいねをした人:
9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • トピック「ページを編集時にブロックのスタイルを変更すると「このブロックでエラーが発生したためプレビューできません。」と表示され、ブロックが壊れる」には新しい返信をつけることはできません。

ドキュメント

Snow Monkey の設定方法やマニュアルを掲載しています。

ドキュメント

フォーラム

Snow Monkey の使い方やカスタマイズについてのご質問・ご要望等はサポートフォーラムで行っています。サポートフォーラムは誰でも閲覧できますが、書き込みできるのは Snow Monkey 購入者のみとなります。

サポートフォーラム

よくあるご質問

Snow Monkey のサービスについて不明な点がある場合は、まずはよくあるご質問をご確認ください。

よくあるご質問

お問い合わせ

よくあるご質問を見ても解決しなかった場合、試用版の申請については問い合わせフォームからお願いいたします。

お問い合わせ