ホームページのコンテンツエリアの余白の設定について

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #56567
    kjn
    参加者
    2

    トピックを新しく立てる方は次の項目も記述してください(要望トピックの場合は不要です)。

    【お使いの Snow Monkey のバージョン】バージョン: 11.1.0
    【お使いのブラウザ】Google Chrome
    【当該サイトのURL】(公開できる場合は書いていただいたほうがスムーズです)

    ===

    いつもお世話になっております。

    カスタマイズ→ホームページ設定→「ホームページのコンテンツエリアに上下余白を追加する」の項目について、チェックを外して「更新」ボタンを押し保存し、ページを確認したところ、余白がついている状態になりました。

    再度カスタマイズを開いたところ、チェックが入っている状態のままになっており、何度保存しなおしてもチェックがついてしまいます。
    カスタマイズ時に表示されるプレビューでは余白はきえているのですが、カスタマイズを閉じて開くと余白が戻ってしまいます。

    お忙しいところ大変申し訳ございませんが、解決策を教えていただけますでしょうか。

     

    0
    #56575
    Kmical Lights
    参加者
    143

    左右余白
    投稿ページのタイトルを表示

    も同様に、チェックを外しても付いてしまうのを確認しました。

    他にもありそうなので見つけたら追記します。

    追記:
    デザインの方
    ・Pure CSS ギャラリーを使用する
    ・ページ上部へ戻るボタンを表示

    がチェック外れない

    なお、チェックボックス系以外は未検証です。

    0
    #56577
    キタジマ タカシ
    キーマスター
    340

    ぐわーバグですかね、確認します!

    0
    #56581
    キタジマ タカシ
    キーマスター
    340

    @Kmical Lights
    下記が $this->get_setting_arg()$this->set_setting_arg() としなければいけないのを $this->get_arg()$this->set_arg() と間違っているからですかね?

    こちらの環境ではそれで改善された気がします(まだ根本の原因究明まではできていません)。

    0
    #56583
    Kmical Lights
    参加者
    143

    @キタジマさん

    2種類のargsの系統を間違えると正しく反映されない、または初期値の表示が正しくなくなるのを確認できたので、それも原因の一つまたは原因そのものかもです。

    後、多分されてないと思いますが、一応の共有を。
    is_admin()を使う形でカスタマイザーフレームワークのset処理をさせると、カスタマイザーの設定のset系で後から(?)設定したcallback要素のfunctionなどでは正しい実行結果にされない不具合になる事も確認取れました。
    多分、プレビュー機能で管理画面のis_admin()がfalseになる為と思われます。

    0
    #56593
    キタジマ タカシ
    キーマスター
    340

    @kjn さん、こちら不具合なのでアップデートして修正します!しばしお待ちください…。

    @Kmical Lights さん、確認ありがとうございます! 修正いれます。

    is_admin()を使う形でカスタマイザーフレームワークのset処理をさせると、カスタマイザーの設定のset系で後から(?)設定したcallback要素のfunctionなどでは正しい実行結果にされない不具合になる事も確認取れました。
    多分、プレビュー機能で管理画面のis_admin()がfalseになる為と思われます。

    ちょっと具体的なコードを見ないとなんともですが、カスタマイザー画面は is_admin() ではなくて is_customize_preview() で判定しないとなので、is_admin() を使うこと自体が正しくないのではないかと思いもます。そういうことではなく…?

    0
    #56595
    Kmical Lights
    参加者
    143

    @北島さん

    そういうことではなく…?

    あ、単純にWP_Customizer_Frameworkを使う処理とか、snow_monkey_post_load_customizerフックをis_admin()で分岐を囲んでしまったのではとか、そう言う感じで言ってました。今回の原因とは無関係だったので気にしないでください。

    is_admin()で処理を囲っていても、一見カスタマイザー画面は表示されるんで…
    でも、プレビューは管理画面では無い為に、プレビュー画面が正しく出なくなってしまったり、そこからのcallbackが呼ばれなかったりして正しく保存されなかったり…と言うだけです。

    後、カスタマイザーのテストして翻訳されてない(?)箇所もあったので共有しときま。
    基本デザイン設定のラベル : Design of widget-titles のまま

    一通りカスタマイザーの値をテストした感じでは、他のセレクトボックスなどは大丈夫そうです。

    1
    #56598
    キタジマ タカシ
    キーマスター
    340

    Snow Monkey v11.1.1 で修正しました! 確認してみてください!

    1
    #56629
    kjn
    参加者
    2

    @キタジマ様
    早速修正いただきまして、ありがとうございます!
    先程、Snow Monkey v11.1.1 で余白のチェックが外れたことを確認しました!
    Snow Monkeyテーマ、とても使いやすく、本当にありがたいです。これからも利用させていただきます!

    @Kmical Lights様
    他のチェックボックスについては頭にはいっておりませんでした・・。
    ご確認いただきまして、ありがとうございました!

    1
    #56651
    キタジマ タカシ
    キーマスター
    340

    解決済みということでトピック閉じます!

    1
10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • トピック「ホームページのコンテンツエリアの余白の設定について」には新しい返信をつけることはできません。