1. ホーム
  2. フォーラム
  3. 不具合報告
  4. 任意のタクソノミーブロックで親カテゴリを選択時に、親カテゴリの記事数がゼロだと子カテゴリに属する記事一覧が表示されない。

任意のタクソノミーブロックで親カテゴリを選択時に、親カテゴリの記事数がゼロだと子カテゴリに属する記事一覧が表示されない。

ホーム フォーラム 不具合報告 任意のタクソノミーブロックで親カテゴリを選択時に、親カテゴリの記事数がゼロだと子カテゴリに属する記事一覧が表示されない。

このトピックには7件の返信が含まれ、2人の参加者がいます。3 週間、 4 日前 キタジマ タカシ さんが最後の更新を行いました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #14047

    Nobuyuki Hiroe
    参加者

    トピックを新しく立てる方は次の項目も記述してください(要望トピックの場合は不要です)。

    【お使いの Snow Monkey のバージョン】v5.6.1
    【お使いのブラウザ】chome,safari,firefox
    【当該サイトのURL】(公開できる場合は書いていただいたほうがスムーズです)

    ===
    任意のタクソノミーブロックで親カテゴリを選択して、子カテゴリに属するすべての記事一覧を表示させようとした場合に、親カテゴリの記事数が0だと、一覧が表示されません。(記事はありませんと表示される)

    もしこれが仕様だとすると、親カテゴリを設定した記事がある場合にはその記事だけが表示されるはずです。

    で、いろいろと試してみると、

    現状では、子カテゴリに属する記事のどれか1つの記事だけに親カテゴリも同時に設定する(2つのカテゴリに属する)と、親カテゴリを設定していない記事も含めて、子カテゴリに属するすべての記事の一覧が表示されるようです。

    これは、不具合なのではと思ったので、ご報告です。

    ちなみに私は基本的にカテゴリは1つだけ指定するので、子カテゴリがある場合は、親カテゴリの記事数はゼロになります。

    しかし任意のタクソノミーブロックの用途を考えると、記事数ゼロの親カテゴリを選択した場合はその子カテゴリに属するすべての記事が表示できるのが理想です。

    現状では1記事だけ親カテゴリと子カテゴリ同時に指定して、すべての記事一覧を表示させていますが、記事数ゼロの親カテゴリを選択した場合には、すべての子カテゴリに属するすべての記事が表示されると嬉しいです!

    よろしくお願いします。

    #14075

    キタジマ タカシ
    キーマスター

    単純に tax_query でタクソノミーとタームIDだけ指定するようにしていたのですが、それだと WordPress の仕様ではそのような動作になるのでしょうね…。子カテゴリがある場合はそれらも tax_query に渡せるように調整してみます。

    #14332

    キタジマ タカシ
    キーマスター

    ちょっと確認です。

    いま、

    ・親カテゴリー(0件)
     ・子カテゴリー(1件)

    という状態で、「親カテゴリー」を選択してテストしているのですが、エディター上では「投稿が見つかりませんでした」と表示され、実際の画面ではちゃんと1件表示されました。エディター上で「見つかりません」になるのはバグなので直さなきゃなと思うのですが、実際の画面上でも表示されない感じでしょうか?

    #14576

    キタジマ タカシ
    キーマスター

    Snow Monkey Blocks v3.5.2 で修正しました。

    #14582

    Nobuyuki Hiroe
    参加者

    ・親カテゴリー(0件)
    ・子カテゴリー(1件)

    という状態で、「親カテゴリー」を選択してテストしているのですが、エディター上では「投稿が見つかりませんでした」と表示され、実際の画面ではちゃんと1件表示されました。エディター上で「見つかりません」になるのはバグなので直さなきゃなと思うのですが、実際の画面上でも表示されない感じでしょうか?

    すみません、返信のチェックがもれていました。
    本日Snow Monkey Blocks v3.5.2 への更新のお知らせを受けて、更新しました。

    結果ですが、
    親カテゴリーがゼロだと、エディター上では「投稿がありません」となり、実際の画面ではきちんと表示されています。(1記事だけ、親カテゴリーも合わせて選択しておくとエディター上でも表示されます)

    以前は実際の画面でも表示されていませんでした。

    ただ今回は、

    ・[任意のタクソノミー] 親カテゴリーを選択したとき、エディター上で「投稿がありません」と表示されることがある不具合を修正。

    というアップデートだったので、エディター上で「投稿がありません」となる状態はなおってない状態です。ブロックを作り直しても同じです。

    実際の画面では表示されるので問題はないですが、一応ご報告まで。

    #14586

    キタジマ タカシ
    キーマスター

    以前は実際の画面でも表示されていませんでした。

    うーん、なんでしょうね、エディター側に変更は入れましたが、表側には変更いれてなくて。

    エディター上で「投稿がありません」となる状態はなおってない状態です。ブロックを作り直しても同じです。

    あ!すみません、コードに間違いを見つけました。修正します。

    #14588

    Nobuyuki Hiroe
    参加者

    Snow Monkey Blocks v3.5.3への早速の更新、ありがとうございました。

    エディターでもばっちり表示できてます。
    これでより便利になりました!
    ありがとうございました〜

    #14589

    キタジマ タカシ
    キーマスター

    確認ありがとうございます!クローズします。

8件の投稿を表示中 - 1 - 8件目 (全8件中)

トピック「任意のタクソノミーブロックで親カテゴリを選択時に、親カテゴリの記事数がゼロだと子カテゴリに属する記事一覧が表示されない。」への新規返信追加は締め切られています。