1. ホーム
  2. フォーラム
  3. 不具合報告
  4. 投稿個別ページが表示されない

投稿個別ページが表示されない

このトピックには7件の返信が含まれ、2人の参加者がいます。2 ヶ月、 1 週前 キタジマ タカシ さんが最後の更新を行いました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #17527

    長井 岳
    参加者

    【お使いの Snow Monkey のバージョン】Version: 6.1.0
    【お使いのブラウザ】chrome
    【当該サイトのURL】http://nagatake.sakura.ne.jp/workers_news/
    【PHP、MySQL のバージョン】 PHP 7.2.17 (CGI版), MySQL 5.7
    【使用しているプラグイン】Gutenberg, Intuitive Custom Post Order
    【WordPress のバージョン】 WordPress 5.2.1

    ===

    個別投稿ページが表示されません。

    プラグインをすべて停止してみましたが、表示されません。また、特にPHPには触れておりません。

    どのような原因が考えられますでしょうか。

    #17528

    キタジマ タカシ
    キーマスター

    なんらかエラーがでているのではないかと思うので、WordPress のデバッグモードを有効にするか、エラーログにエラーが出ていないか確認してみてください。

    #17531

    長井 岳
    参加者

    リンクを参照に、WP_DEBUG’, trueにしてみたのですが、特にエラーは表示されないです。

    #17532

    キタジマ タカシ
    キーマスター

    うーん、なるほどです…。エラーログのほうはどうでしょうか?

    子テーマはつかっていますかね? もし使っているなら Snow Monkey に切り替えてみてください。
    あと、固定ページは表示されますか? 適当な固定ページをつくって表示されるか試してみてください!

    #17534

    長井 岳
    参加者

    エラーログのほうはどうでしょうか?

    エラーログは、デバックモードで出力するものですか? もしくはダッシュボードに表示されるのですか? どちらにせよ特に表示がないです。

    子テーマはつかっていますかね? もし使っているなら Snow Monkey に切り替えてみてください。
    あと、固定ページは表示されますか? 適当な固定ページをつくって表示されるか試してみてください!

    子テーマは使用しておりません。固定ページを作ってみました。こちらも表示されないです。

    http://nagatake.sakura.ne.jp/workers_news/test

    #17545

    キタジマ タカシ
    キーマスター

    エラーログは、デバックモードで出力するものですか? もしくはダッシュボードに表示されるのですか? どちらにせよ特に表示がないです。

    さくらだと

    ですかね。投稿か固定ページを開いたあとエラーログになにかエラーが出ていないか確認してみてください。

    子テーマは使用しておりません。固定ページを作ってみました。こちらも表示されないです。

    うーむ、なるほど…。以前に一度、何らかの理由でテーマのインストール/アップデートに失敗して、テーマの一部のファイルが正しくサーバーにアップロードされていなかった、というのがありました。サーバー上の wp-content/themes/snow-monkey/ の中に、 singular.php があるか確認してみてください。

    #17546

    長井 岳
    参加者

    [Wed Jun 05 13:18:38.017019 2019] [autoindex:error] [pid 13820] [client 58.3.20.53:0] AH01276: Cannot serve directory /home/nagatake/www/: No matching DirectoryIndex (index.html,index.htm,index.shtml,index.shtm,index.cgi,index.php,index.hdml) found, and server-generated directory index forbidden by Options directive

    さくらのサーバーの上記のエラーがありました。でも関係なさそうですね。

    singular.phpは、テーマファイルの中にありました。

     

    あらためて一から組みなおしておりまして、現状では問題なく動いております。

    ですので、とりあえず大丈夫です。

    また問題がお聞きします。

    お手数おかけしました。ありがとうございました。

    #17807

    キタジマ タカシ
    キーマスター

    なるほど…。原因がわからずじまいですが、とりあえず解決したということで、トピッククローズします。またおかしくなったときは教えていただければと思います!

8件の投稿を表示中 - 1 - 8件目 (全8件中)

トピック「投稿個別ページが表示されない」への新規返信追加は締め切られています。