表紙(固定ページ)を更新するとエラーメッセージが出るが、更新済みで正常に使える

0
いいねをした人: 居ません
13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • 投稿者
    投稿
  • #136191
    Katsuyuki Murasaka
    参加者
    17

    【お使いの Snow Monkey のバージョン】バージョン: 25.3.3
    【お使いの Snow Monkey Blocks のバージョン】バージョン 20.4.2
    【お使いの Snow Monkey Editor のバージョン】バージョン 9.3.3
    【お使いのブラウザ】  Google chrome
    【当該サイトのURL】https://67care.jp/

    ### 実現したいこと

    メインページ表紙を更新すると失敗と表示されますが、ページを離脱すると更新済みになって修正済みになっています。ページを表示するの左下にメッセージは出ません。

    ブログ記事ではこのようなメッセージが出ません。

    ### 発生している問題

    更新しても更新に失敗と出る。更新はできている。

    ### 試したこと

    無し

    更新に失敗したとメッセージが出る

    更新に失敗したとメッセージが出る

    更新してページを離れるときの警告メッセージ

    戻るとバージョンが違うと出ます

    0
    いいねをした人: 居ません
    #136195
    キタジマ タカシ
    参加者
    2201

    「更新に失敗しました」がでたとき、ブラウザのコンソールに何かエラーが出ていますか?

    0
    いいねをした人: 居ません
    #136199
    Katsuyuki Murasaka
    参加者
    17

    こんなんが出ています。

    0
    いいねをした人: 居ません
    #136201
    Katsuyuki Murasaka
    参加者
    17

    こんなんが出ています。

    0
    いいねをした人: 居ません
    #136205
    キタジマ タカシ
    参加者
    2201

    スクショの中に赤いバツマークと、その横に9とでていますよね。そこをクリックするとエラーメッセージが見れるので、出ているメッセージをここに全部貼り付けお願いします。

    0
    いいねをした人: 居ません
    #136206
    Katsuyuki Murasaka
    参加者
    17

    これで良いですか?

    post.php:1 Third-party cookie will be blocked. Learn more in the Issues tab.
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.4.1
    2data.min.js:2 Store “jetpack-modules” is already registered.
    i @ data.min.js:2
    rich-text.min.js:2 Format “core/superscript” is already registered to handle bare tag name “sup”.
    W @ rich-text.min.js:2
    rich-text.min.js:2 Format “core/subscript” is already registered to handle bare tag name “sub”.
    W @ rich-text.min.js:2
    data.min.js:2 Store “jetpack-connection” is already registered.
    i @ data.min.js:2
    data.min.js:2 Store “jetpack-modules” is already registered.
    i @ data.min.js:2
    admin.js?ver=c81a4d4bfe064553142e:1 Download the Vue Devtools extension for a better development experience:

    admin.js?ver=c81a4d4bfe064553142e:1 You are running Vue in development mode.
    Make sure to turn on production mode when deploying for production.
    See more tips at https://vuejs.org/guide/deployment.html
    my-block-editor-plugin-script.js?ver=1.0:31 Uncaught TypeError: Cannot read properties of null (reading ‘addEventListener’)
    at HTMLDocument.<anonymous> (my-block-editor-plugin-script.js?ver=1.0:31:12)
    react-dom.min.js:10 An iframe which has both allow-scripts and allow-same-origin for its sandbox attribute can escape its sandboxing.
    Qr @ react-dom.min.js:10
    page.js:32 <span id=​”hjT-iyy” data-script>​</span>​
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.4.1
    post.php?post=30822&action=edit&classic-editor:1 Uncaught DOMException: Failed to read the ‘cssRules’ property from ‘CSSStyleSheet’: Cannot access rules
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:79083
    at StyleSheetList.forEach (<anonymous>)
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:79013
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:79289
    post.php:1 Third-party cookie will be blocked. Learn more in the Issues tab.
    deprecated.min.js:2 wp.editor.RichTextShortcut is deprecated since version 5.3 and will be removed in version 6.2. Please use wp.blockEditor.RichTextShortcut instead.
    i @ deprecated.min.js:2
    deprecated.min.js:2 wp.editor.RichTextToolbarButton is deprecated since version 5.3 and will be removed in version 6.2. Please use wp.blockEditor.RichTextToolbarButton instead.
    i @ deprecated.min.js:2
    deprecated.min.js:2 wp.editor.InspectorControls is deprecated since version 5.3 and will be removed in version 6.2. Please use wp.blockEditor.InspectorControls instead.
    i @ deprecated.min.js:2
    deprecated.min.js:2 wp.editor.PanelColorSettings is deprecated since version 5.3 and will be removed in version 6.2. Please use wp.blockEditor.PanelColorSettings instead.
    i @ deprecated.min.js:2
    deprecated.min.js:2 Button isDefault prop is deprecated since version 5.4 and will be removed in version 6.2. Please use variant=”secondary” instead.
    i @ deprecated.min.js:2
    /wp-json/wp/v2/pages/30822?_locale=user:1

    Failed to load resource: the serve

    0
    いいねをした人: 居ません
    #136207
    Katsuyuki Murasaka
    参加者
    17

    0
    いいねをした人: 居ません
    #136234
    Katsuyuki Murasaka
    参加者
    17

    おはようございます。

    「Site Kit by Google」を停止したら正常になりました。アナリティクス4のエラーが出ていました。

    以上、報告です。

    0
    いいねをした人: 居ません
    #136235
    Katsuyuki Murasaka
    参加者
    17

    エラーは8個になっています。

    0
    いいねをした人: 居ません
    #136249
    キタジマ タカシ
    参加者
    2201

    「Site Kit by Google」を停止したら正常になりました。アナリティクス4のエラーが出ていました。

    Site Kit by Google の不具合であれば、Site Kit by Google のアップデートを待てば解消されるのかなとは思うのですが、Snow Monkey、あるいはその他使用しているプラグインとの相性問題だったとすると悩ましいですね…。Site Kit by Google を有効化して、アナリティクス4を正しく設定しても「更新に失敗しました」になりますか?

    個人的に気になったのは、コンソールにエラーがでている、Uncaught TypeError: Cannnot read properties of nullUncaught DOMException: Failled to read the 'cssRules' property です。僕も詳しくはないのですが、どちらもエディター自体が不具合を起こすレベルのエラーに見えます。

    Uncaught TypeError: Cannnot read properties of null の横に my-block-editor-plug...cript.js?ver=1.0:31 というリンク文字があると思いますが、そこで右クリックして「リンクのアドレスをコピー」したものをここに貼り付けてもらえますか?

    0
    いいねをした人: 居ません
    #136250
    Katsuyuki Murasaka
    参加者
    17

    アナリティクス4の設定は調べてやってみますのでお待ち下さい。

    訂正です。更新できましたとなりましたが、再び見たらバージョンが古いと出ました。

    https://67care.jp/blog/wp-content/plugins/ChatGPT_to_Title-main/js/my-block-editor-plugin-script.js?ver=1.0
    
    page.js:32 <span id=​"hjT-iyy" data-script>​</span>​
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.4.1
    data.min.js:2 Store "jetpack-modules" is already registered.
    i @ data.min.js:2
    data.min.js:2 Store "jetpack-modules" is already registered.
    i @ data.min.js:2
    rich-text.min.js:2 Format "core/superscript" is already registered to handle bare tag name "sup".
    W @ rich-text.min.js:2
    rich-text.min.js:2 Format "core/subscript" is already registered to handle bare tag name "sub".
    W @ rich-text.min.js:2
    data.min.js:2 Store "jetpack-connection" is already registered.
    i @ data.min.js:2
    data.min.js:2 Store "jetpack-modules" is already registered.
    i @ data.min.js:2
    admin.js?ver=c81a4d4bfe064553142e:1 Download the Vue Devtools extension for a better development experience:
    ttps://github.com/vuejs/vue-devtools
    admin.js?ver=c81a4d4bfe064553142e:1 You are running Vue in development mode.
    Make sure to turn on production mode when deploying for production.
    See more tips at https://vuejs.org/guide/deployment.html
    react-dom.min.js:10 An iframe which has both allow-scripts and allow-same-origin for its sandbox attribute can escape its sandboxing.
    Qr @ react-dom.min.js:10
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.4.1
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 3.4.1
    page.js:32 <span id=​"hjT-iyy" data-script>​</span>​
    post.php?post=30822&action=edit&classic-editor:1 Uncaught DOMException: Failed to read the 'cssRules' property from 'CSSStyleSheet': Cannot access rules
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:78512
    at StyleSheetList.forEach (<anonymous>)
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:78442
    at https://67care.jp/blog/wp-admin/post.php?post=30822&action=edit&classic-editor:1:78718
    post.php:1 Third-party cookie will be blocked. Learn more in the Issues tab.
    0
    いいねをした人: 居ません
    #136254
    キタジマ タカシ
    参加者
    2201

    訂正です。更新できましたとなりましたが、再び見たらバージョンが古いと出ました。

    んーなんでしょうね。実際、書き換えたところは正しく保存されているのでしょうか?
    正しく保存されている場合、何らかの要因で意図しない部分が自動的に変更されているけど保存はされていない、という状態になっているのだと思います。検証するとしたら、

    1) 更新をクリック
    2) コードエディターに切り替えて、表示されたコードを適当なテキストファイルに保存
    3) 画面をリロード
    4) 「バージョンが古い」とでていると思うので、それも表示されたコードを適当なファイルに保存
    5) (2) で保存したコードと (4) で保存したコードを見比べる

    という感じでしょうか…。

    ttps://67care.jp/blog/wp-content/plugins/ChatGPT_to_Title-main/js/my-block-editor-plugin-script.js?ver=1.0

    ありがとうございます。ものくろさんがつくったプラグインですかね? 先程のスクショをみせて、こういうエラーがでているよとお伝えしたほうが良いかもしれません(今回のトピックの問題と関連があるかはわかりません)。

    ちなみに、ChatGPT_to_Title を停止したら「バージョンが古い」がでなくなったりしませんかね?

    0
    いいねをした人: 居ません
    #136255
    Katsuyuki Murasaka
    参加者
    17

    アナリティクス4のエラーは解消しましたが、現象は同じです。

    0
    いいねをした人: 居ません
13件の投稿を表示中 - 1 - 13件目 (全13件中)
  • トピック「表紙(固定ページ)を更新するとエラーメッセージが出るが、更新済みで正常に使える」には新しい返信をつけることはできません。

ドキュメント

Snow Monkey の設定方法やマニュアルを掲載しています。

ドキュメント

フォーラム

Snow Monkey の使い方やカスタマイズについてのご質問・ご要望等はサポートフォーラムで行っています。サポートフォーラムは誰でも閲覧できますが、書き込みできるのは Snow Monkey 購入者のみとなります。

サポートフォーラム

よくあるご質問

Snow Monkey のサービスについて不明な点がある場合は、まずはよくあるご質問をご確認ください。

よくあるご質問

お問い合わせ

よくあるご質問を見ても解決しなかった場合、試用版の申請については問い合わせフォームからお願いいたします。

お問い合わせ

Snow Monkey は Gutenberg ブロックエディターに対応した 100%GPL の WordPress テーマです。拡張性を意識した開発をおこなっており、カスタマイザーとブロックでスピーディーにサイトを立ち上げるだけでなく、CSS やフックを駆使した高度なカスタマイズにも柔軟に対応できます。