Snow Monkey Editorを有効にすると、『このブロックでエラーが発生したためプレビューできません。』と表示される

0
いいねをした人: 居ません
11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • 投稿者
    投稿
  • #78861
    Ryo
    閲覧者
    3

    【お使いの Snow Monkey のバージョン】: 14.3.5
    【お使いの Snow Monkey Blocks のバージョン】 11.4.1
    【お使いの Snow Monkey Editor のバージョン】 5.0.6
    【お使いのブラウザ】 Google Chrome

    ### 発生している問題

    Snow Monkey BlockとSnow Monkey Editorを有効にすると、投稿記事の編集画面で、下記画像のようにエラーが発生します。(Snow Monkey Blocks の吹き出しブロック etc…)

     

    編集ができないだけで、サイトの表示には問題ありませんでした。
    また、Snow Monkey Editorを停止すれば、エラーは出ず、問題なく編集可能でした。

    お忙しいところ恐れ入りますが、ご確認いただけますと幸いです。

    ### 試したこと

    過去にも全く同じフォーラムがあり、そこではChromeの『Cookieと他のサイトデータ』を削除したところ問題なく表示されました。と書いてありそれを試しましたが解決できませんでした。

    0
    いいねをした人: 居ません
    #78863
    Ryo
    閲覧者
    3

    またGoogle Chrome以外のブラウザでも試しましたがダメでした

    0
    いいねをした人: 居ません
    #78881
    キタジマ タカシ
    参加者
    1563

    他のプラグインとの相性で発生している可能性はあるかもです。Snow Monkey Editor 以外のプラグインをすべて停止して、1つずつ有効化しながら試していくとどこに原因があるのかわかるかもしれません。

    また、エラーが出たときにブラウザのデベロッパーツールの console にエラーメッセージがでているのではないかと思います。もしでているようなら共有をお願いします!

    0
    いいねをした人: 居ません
    #78890
    Ryo
    閲覧者
    3

    試してみます。

    コンソールのエラーはこれです。

    Uncaught TypeError: Failed to execute 'observe' on 'IntersectionObserver': parameter 1 is not of type 'Element'.
    at HTMLDocument. (app.js?ver=1623723716:1)
    16react-dom.min.js?ver=16.13.1:125
    
    TypeError: Cannot read property 'length' of undefined
    at editor-extension.js?ver=1621041574:2
    at we (react-dom.min.js?ver=16.13.1:84)
    at zj (react-dom.min.js?ver=16.13.1:226)
    at Th (react-dom.min.js?ver=16.13.1:152)
    at tj (react-dom.min.js?ver=16.13.1:152)
    at Te (react-dom.min.js?ver=16.13.1:146)
    at react-dom.min.js?ver=16.13.1:61
    at unstable_runWithPriority (react.min.js?ver=16.13.1:25)
    at Da (react-dom.min.js?ver=16.13.1:60)
    at Pg (react-dom.min.js?ver=16.13.1:61)
    Me @ react-dom.min.js?ver=16.13.1:125
    0
    いいねをした人: 居ません
    #78891
    キタジマ タカシ
    参加者
    1563

    ありがとうございます! そのエラーだと Snow Monkey Editor 単体な気がします。どういうときに再現してどういうときに再現しないのかはまだわかりませんが…。

    0
    いいねをした人: 居ません
    #78910
    Ryo
    閲覧者
    3

    Snow Monkey Editor を停止したら普通に表示されます。対処法としては何かございますでしょうか。

    0
    いいねをした人: 居ません
    #78926
    キタジマ タカシ
    参加者
    1563

    Snow Monkey Editor 以外になにか使っているプラグインはありますか? Snow Monkey Editor 単体な気はするのですが、こちらでは再現できていないので Snow Monkey Editor 以外で使用されているプラグインとの競合がある可能性もあるのではないかと予想しています。

    現状対処法としては Snow Monkey Editor を停止するか、競合しているプラグインを停止するしか無いかなと思います。

    0
    いいねをした人: 居ません
    #78984
    Ryo
    閲覧者
    3

    使用しているプラグインはSnow Monkey Editorの他に

    ・Akismet Anti-Spam (アンチスパム)
    
    ・All in One SEO
    
    ・All-in-One WP Migration
    
    ・Easy Google Fonts
    
    ・Google Analytics for WordPress by MonsterInsights
    
    ・My Snow Monkey
    
    ・Snow Monkey Blocks
    
    ・Table of Contents Plus
    
    ・WordPress インポートツール
    
    ・WP Multibyte Patch

    になります。

    0
    いいねをした人: 居ません
    #78988
    キタジマ タカシ
    参加者
    1563

    繰り返しになりますが、Snow Monkey Editor 以外のプラグインをすべて停止するとエラーはどうなりますか?

    また、解消したとして、1つずつ有効化しながら試していくと何を有効化したときにエラーが再発しますか?
    解消しなかった場合は Snow Monkey Editor 単体で問題が発生する可能性が濃厚です。ただ、僕の環境では再現しない + 他の方からは報告がないことから、単体の問題だったとしても何らかの設定をしたとき、あるいは何らかの設定の組み合わせで発生する問題なのかなと予想しています。

    0
    いいねをした人: 居ません
    #79016
    Ryo
    閲覧者
    3

    Table of Contents Plusこちらのプラグインを無効化したら治りました。

    お騒がせしてしまい申し訳ありません。お忙しいところありがとうございました

    0
    いいねをした人: 居ません
    #79057
    キタジマ タカシ
    参加者
    1563

    ご報告ありがとうございます!
    Table of Contents Plus を入れて確認してみます。

    0
    いいねをした人: 居ません
11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • トピック「Snow Monkey Editorを有効にすると、『このブロックでエラーが発生したためプレビューできません。』と表示される」には新しい返信をつけることはできません。

ドキュメント

Snow Monkey の設定方法やマニュアルを掲載しています。

ドキュメント

フォーラム

Snow Monkey の使い方やカスタマイズについてのご質問・ご要望等はサポートフォーラムで行っています。サポートフォーラムは誰でも閲覧できますが、書き込みできるのは Snow Monkey 購入者のみとなります。

サポートフォーラム

よくあるご質問

Snow Monkey のサービスについて不明な点がある場合は、まずはよくあるご質問をご確認ください。

よくあるご質問

お問い合わせ

よくあるご質問を見ても解決しなかった場合、試用版の申請については問い合わせフォームからお願いいたします。

お問い合わせ