Snow Monkey Editorを有効にすると、『このブロックでエラーが発生したためプレビューできません。』と表示される

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #48811
    Shingo Sasaki
    参加者
    6

    【お使いの Snow Monkey のバージョン】
    WordPress 5.3.2
    Snow Monkey 9.3.4
    Snow Monkey Block 7.4.1
    Snow Monkey Editor 1.1.0

    PHP 7.3.14

    【お使いのブラウザ】
    Google Chrome

     

    Snow Monkey BlockとSnow Monkey Editorを有効にすると、投稿記事の編集画面で、下記画像のようにエラーが発生します。

    TypeError: Cannot read property 'filter' of undefined
    at _ (editor-extension.js?ver=1585022094:11)
    at WithSnowMonkeyEditorEditingLockByRoleBlockEdit(WithSnowMonkeyEditorDateTimeBlockEdit(WithSnowMonkeyEditorAnimationBlockEdit(WithSnowMonkeyEditorHiddenByRoleBlockEdit(WithSnowMonkeyEditorHiddenBySizeBlockEdit(WithMultipleValidation(WithInspectorControl(WithInspectorControl(WithToolbarControls(Component))))))))) (editor-extension.js?ver=1585022094:11)
    at je (react-dom.min.js?ver=16.9.0:78)
    at ph (react-dom.min.js?ver=16.9.0:215)
    at lh (react-dom.min.js?ver=16.9.0:126)
    at O (react-dom.min.js?ver=16.9.0:121)
    at ze (react-dom.min.js?ver=16.9.0:118)
    at react-dom.min.js?ver=16.9.0:53
    at unstable_runWithPriority (react.min.js?ver=16.9.0:26)
    at Ma (react-dom.min.js?ver=16.9.0:52)
    ve @ react-dom.min.js?ver=16.9.0:103
    f.componentDidCatch.c.callback @ react-dom.min.js?ver=16.9.0:114
    yg @ react-dom.min.js?ver=16.9.0:62
    xg @ react-dom.min.js?ver=16.9.0:61
    Ti @ react-dom.min.js?ver=16.9.0:148
    unstable_runWithPriority @ react.min.js?ver=16.9.0:26
    Ma @ react-dom.min.js?ver=16.9.0:52
    Ia @ react-dom.min.js?ver=16.9.0:140
    ze @ react-dom.min.js?ver=16.9.0:118
    (anonymous) @ react-dom.min.js?ver=16.9.0:53
    unstable_runWithPriority @ react.min.js?ver=16.9.0:26
    Ma @ react-dom.min.js?ver=16.9.0:52
    mg @ react-dom.min.js?ver=16.9.0:52
    V @ react-dom.min.js?ver=16.9.0:52
    Be @ react-dom.min.js?ver=16.9.0:119
    xi @ react-dom.min.js?ver=16.9.0:39

    編集ができないだけで、サイトの表示には問題ありませんでした。
    また、Snow Monkey Editorを停止すれば、エラーは出ず、問題なく編集可能でした。

    お忙しいところ恐れ入りますが、ご確認いただけますと幸いです。

    0
    #48815
    キタジマ タカシ
    キーマスター
    287

    ぐわー、なんでしょうね…。このエラーが発生したブロックは、なんのブロックでしょうか? (コアの段落ブロック、Snow Monkey Blocks の吹き出しブロック etc…)

    0
    #48817
    Shingo Sasaki
    参加者
    6

    Snow Monkey Editorを有効にすると、全てのブロックでエラーが発生します・・・
    (一般ブロック、Snow Monkey Blocks共通ブロック・セクションなど・・・)

     

    プラグインは、

    • Snow Monkey Blocks
    • Snow Monkey Editor

    のみ有効にし、それ以外は停止にしています。

    サーバーは、Xサーバーを使用しており、

    • サーバーキャッシュ設定
    • ブラウザキャッシュ設定

    なども、OFFにしています。

    0
    #48821
    キタジマ タカシ
    キーマスター
    287

    こちらのいくつかの環境で試してみたのですが、いずれの環境でも再現できませんでした。

    ブラウザは Chrome とのことですが、他のブラウザで開いても同じようにエラーがでますか?

    0
    #48836
    Shingo Sasaki
    参加者
    6

    解決しました。
    Cookieが原因で上手く表示されていなかったようです。

     

    Chromeの『Cookieと他のサイトデータ』を削除したところ問題なく表示されました。

    お騒がせして申し訳ありませんでした。

    1
    #48840
    キタジマ タカシ
    キーマスター
    287

    なんと!解決して良かったです。でもなぜそれが原因でこわれたのかがちょっとわからないので、気持ちわるさは残りますね…^^;

    1
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • トピック「Snow Monkey Editorを有効にすると、『このブロックでエラーが発生したためプレビューできません。』と表示される」には新しい返信をつけることはできません。